System Status

Time & Attendance app loading issues

Incident Report for Rippling

Resolved

This incident has been resolved.
Posted Nov 24, 2025 - 01:29 UTC

Monitoring

We have identified the root causes and continue to monitor the health
Posted Nov 22, 2025 - 03:52 UTC

Update

Access to Time & Attendance has recovered. We are continuing to investigate to address the root cause.
Posted Nov 21, 2025 - 20:06 UTC

Investigating

We are investigating issues that are preventing users from loading the Time & Attendance app
Posted Nov 21, 2025 - 19:53 UTC
This incident affected: Rippling App.