System Status

Issues logging into Rippling

Incident Report for Rippling

Resolved

This incident has been resolved.
Posted Mar 08, 2026 - 18:10 UTC

Monitoring

We added a database index and have mitigated the issue
Posted Mar 08, 2026 - 15:20 UTC

Update

The impact has been mitigated, with app access operational again
Posted Mar 08, 2026 - 15:09 UTC

Investigating

We reverted the issue that was believed to be the root cause, but it did not fully resolve the issue. We are continuing to investigate the root cause while working on mitigating the impact.
Posted Mar 08, 2026 - 15:00 UTC

Identified

Access to the Rippling app login page is slow due to high database load. We have identified the root cause and are working on a fix.
Posted Mar 08, 2026 - 14:41 UTC
This incident affected: Rippling App.