System Status

Issue with WiFi policies

Incident Report for Rippling

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 12, 2025 - 15:12 UTC

Investigating

- We are confident that this issue is affecting WiFi policies, and not other policies
- The issue is affecting approximately 200 companies
- Based on our investigation so far, se believe there is a race condition that is resulting in some WiFi policies being removed
- We have a code change ready to deploy that will mitigate most of the issue as we continue to investigate the root cause
- Our engineering team will continue to investigate overnight, and we will come back with another update first in the morning
Posted Sep 12, 2025 - 03:18 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Sep 11, 2025 - 23:30 UTC

Investigating

Our engineering team is investigating an issue with the deployment of WiFi policies that results in the policy being removed and re-added multiple times. This results in devices losing and gaining WiFi connection repeatedly.
Posted Sep 11, 2025 - 20:21 UTC
This incident affects: Device & Inventory Management (Devices app).