System Status

Rippling app is down

Incident Report for Rippling

Resolved

This incident has been resolved.
Posted Jul 27, 2026 - 18:37 UTC

Update

The incident is mitigated, as app performance metrics are back to normal levels.
Posted Jul 27, 2026 - 17:08 UTC

Update

Access to the Rippling app is restored. We are monitoring site health and performance.
Posted Jul 27, 2026 - 16:32 UTC

Update

We are in the middle of rolling back the latest deployment. Performance remains degraded while the rollback is in motion. Next update within 10 minutes.
Posted Jul 27, 2026 - 16:23 UTC

Investigating

We are investigating issues where users are unable to access the Rippling web and mobile apps. We will provide an update within the next 10 minutes.
Posted Jul 27, 2026 - 16:11 UTC
This incident affected: Rippling App.