System Status

Device management functionality is degraded
Incident Report for Rippling
Resolved
This incident has been resolved.
Posted Mar 15, 2024 - 20:18 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 15, 2024 - 19:51 UTC
Investigating
We are currently investigating this issue.
Posted Mar 15, 2024 - 18:55 UTC
This incident affected: Device & Inventory Management (Devices app).