System Status

Device Trust disruption

Incident Report for Rippling

Update

Chrome version 142 prompts users to allow sites to make local network calls. This impacts Device Trust, which relies on a local network call to allow trusted devices to access these sites.

We are working on a fix to this issue, which will be deployed between Friday Oct 31 and Monday Nov 3.
Posted Oct 30, 2025 - 18:16 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Oct 30, 2025 - 15:48 UTC

Investigating

There is a disruption to our device trust product on Chrome 142. Engineering is investigating.
Posted Oct 29, 2025 - 21:34 UTC
This incident affects: Device & Inventory Management (Devices app).