System Status

Increased site latency detected

Incident Report for Rippling

Resolved

This incident has been resolved.
Posted Mar 14, 2025 - 23:48 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 14, 2025 - 19:21 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 14, 2025 - 19:16 UTC

Investigating

We are currently investigating this issue.
Posted Mar 14, 2025 - 17:32 UTC
This incident affected: Rippling App.