System Status

Issues accessing Rippling live chat and support email

Incident Report for Rippling

Resolved

The technical outage impacting our live chat and email support has been fully resolved. All support channels are operating normally, and our team is actively responding to all pending inquiries.
Posted Sep 16, 2026 - 13:34 UTC

Update

The system outage affecting live chat and support emails remains ongoing. We are continuing to monitor the situation and will provide another update in 30 minutes or sooner if additional information becomes available.
Posted Sep 16, 2026 - 12:21 UTC

Identified

We are currently experiencing a technical outage, impacting our live chat and support email systems. We'll provide an update in 30 minutes or sooner if additional information becomes available.
Posted Sep 16, 2026 - 11:22 UTC