System Status

Site performance is degraded

Incident Report for Rippling

Resolved

This incident has been resolved.
Posted Jul 07, 2026 - 19:06 UTC

Identified

We have identified the task that was overloading the system and have mitigated the issue. There were timeouts occurring for ~10 minutes but the site is operational again.
Posted Jul 07, 2026 - 17:08 UTC

Investigating

We are investigating degraded performance of the Rippling app loading. We will share an update in the next 10 minutes.
Posted Jul 07, 2026 - 16:51 UTC
This incident affected: Rippling App.