System Status

Issues accessing Payroll

Incident Report for Rippling

Resolved

Issue is now resolved. We have automatically extended the approval deadline for runs that had an approval date of November 5th. US-funded pay runs now have an approval time of 5pm PT, and Canada-funded runs have an approval deadline of 4pm PT.
Posted Nov 05, 2025 - 20:02 UTC

Identified

We are aware of an issue where users are unable to access the Payroll app. The root cause has been identified and will be resolved within the next hour.
Posted Nov 05, 2025 - 19:04 UTC