System Status

Issues loading saved payroll reports

Incident Report for Rippling

Resolved

The issue affecting saved payroll reports has been resolved, and report access has been restored.
Posted Sep 01, 2026 - 04:20 UTC

Update

We have restored access to affected saved payroll reports for customers in the United States. We are continuing work to restore report access for affected customers in the European Union and will provide another update once restoration is complete.
Posted Sep 01, 2026 - 03:44 UTC

Identified

We have identified an issue preventing some saved payroll reports from loading when certain payroll fields are included. We are implementing a fix and will provide another update once report access has been restored.
Posted Aug 31, 2026 - 22:37 UTC
This incident affected: Data (Reports & Dashboards).