System Status

Issue with Mac devices upgrading to macOS 26 (Tahoe)

Incident Report for Rippling

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Sep 17, 2025 - 00:30 UTC

Identified

Our engineering team has identified an issue with Mac devices upgrading to macOS 26 (Tahoe) despite having a policy in place to defer major upgrades. This has occurred for companies with an OS update policy that has both deferral and major upgrade enforcement settings in place.

We are in the process of implementing a fix for this issue. For devices that have not already upgraded, the fix will also prevent these devices from upgrading.
Posted Sep 16, 2025 - 20:09 UTC
This incident affects: Device & Inventory Management (Devices app).