System Status

Asynchronous job queue resulting in stale services

Incident Report for Rippling

Resolved

This incident has been resolved.
Posted Jul 28, 2026 - 05:17 UTC

Monitoring

To mitigate a previous incident, non-critical asynchronous tasks were paused on Monday, July 27 at 9:30a PT and re-enabled around 3:30p PT. We are still working through the task backlog, and some things across Rippling - like group membership - will be stale until the remaining jobs catch up.
Posted Jul 28, 2026 - 02:23 UTC
This incident affected: Rippling App.