System Status

Increased site latency
Incident Report for Rippling
Resolved
This incident has been resolved. Site performance should be back to normal.
Posted Aug 07, 2023 - 17:35 UTC
Monitoring
We've stopped a data migration job that is believed to be contributing, and we're now seeing site latency return back to baseline numbers. The site latency should now be back to normal, but we are continuing to monitor.
Posted Aug 07, 2023 - 16:26 UTC
Investigating
There is degraded performance across the Rippling application, with certain pages loading slowly. We are investigating the issue.
Posted Aug 07, 2023 - 16:01 UTC
This incident affected: Rippling App.