System Status

New device ordering is temporarily down due to ongoing issues with our partner Ingram Micro.

Incident Report for Rippling

Resolved

This incident has been resolved.
Posted Jul 09, 2025 - 23:59 UTC

Update

We are continuing to monitor for any further issues.
Posted Jul 09, 2025 - 17:32 UTC

Update

Ingram Micro's systems are now functional. We are continuing to monitor for any further issues.
Posted Jul 09, 2025 - 17:32 UTC

Monitoring

Ingram Micro's systems are now functional. We are continuing to monitor for any further issues.
Posted Jul 09, 2025 - 17:29 UTC

Investigating

Due to a cybersecurity incident affecting our partner, Ingram Micro, we have temporarily disabled new device ordering. Our security team is closely partnering with Ingram Micro to fully understand the scope of the incident and any potential impacts to our customers. As of now, we have not confirmed any impact to Rippling customers. You can find more information about the incident here: https://www.businesswire.com/news/home/20250705035732/en/Ingram-Micro-Issues-Statement-Regarding-Cybersecurity-Incident
Posted Jul 07, 2025 - 21:47 UTC
This incident affected: Device & Inventory Management (Devices app).